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1. Introduction 
 
The standard Risø TL/OSL reader detects light emitted from a sample when 
stimulated thermally or optically. The emitted light intensity is detected as the 
number of photons in subsequent timeslots called channels. The minimum channel 
width is 2 ms. 
The Photon Timer Attachment makes it possible to record when each individual 
photon is detected with very high time resolution (0.1/1 ns). This may be useful in 
connection with pulsed stimulation. 
 
The standard Risø TL/OSL reader does Continuous Wave optical stimulation. With 
the Pulsed OSL attachment installed you may do pulsed stimulation as illustrated in 
the figure below 
 

 
 (cf. Guide to “The Risø Pulsed OSL attachment”) 
This attachment allows pulsed stimulation the LEDs in the stimulation head. It also 
provides the ability to gate the light detected, so only light in the off-period is 
detected. 
 
The photon Timer is used in connection with the Pulsed OSL attachment. The 
Photon Timer records all photon events sequentially in a list file. For each 
stimulation pulse a marker is inserted in the list file, and each photon detected during 
the subsequent pulse period (pulse period = on-time + off-time) is recorded with its 
photon arrival time. This is illustrated in the figure below where the plot shows the 
arrival of photons relative to the stimulation pulses, and the list to the right in the 
figure illustrates the recorded list of photon events. 
 
 

 
 
This method gives us full flexibility in the post processing, at the cost of increased 
file size.  
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The  program  PTanalyse allows you to present and analyse the Photon Timer data 
acquired. PTanalyse is included in the software package for the Risø TL/OSL 
Reader. 
 
This User Manual describes how to install the attachment, how to acquire Photon 
Timer data and how to analyse the Photon Timer data. 
 
The Pulsed OSL attachment and the Photon Timer attachment have been presented 
in : 
 

Radiation Measurements 44 (2009) 571-575,  
Development of pulsed stimulation and Photon Timer attachments to the Risø 
TL/OSL reader,  
T. Lapp, M. Jain, C. Ankjærgaard, L. Pirtzel 

 

2. Installation 
 
The Photon Timer attachment consists of 
 

 An extension of the Pulsed OSL attachment with extra control signals for the 
Photon Timer (ORTEC 9353 Time Digitizer or PicoQuant TimeHarp 260) 
board 

 
 A Photon Timer board to be installed in a PC PCI-slot (ORTEC 9353 Time 

Digitizer) or PCI-Express-slot (PicoQuant TimeHarp 260), with software 
driver 
 

 3 connection cables for connecting the Photon Timer board to the Pulsed 
OSL attachment board 

 
 A software license for the sequence editor extension and a program 

(PTanalyse) for analysis of Photon timer data  
 
The Photon Timer (ORTEC 9353) board is installed as described in the “Hardware 
and Software Users’s Manual” that comes with the board. Also the standard 
software for the ORTEC 9353 board is installed as described in the manual. 
 
The Photon Timer -PicoQuant TimeHarp 260 board is described in the “TimeHarp 
260” manual that comes with the board. This is how installation is done:  

1. Install the Risø TL/OSL software package.  
2. The TimeHarp260 board is installed in the PC in the PCI-Express slot, and 

the 4-pin power plug is connected to the internal PC-power supply. An 
extension power cable is also supplied, which may be needed on some PC 
models.  

3. When The PC is turned on after installation of the board, the operating 
system automatically detects the new hardware. It will ask for the driver, and 
you browse to the driver directory that has been installed with the software 
“<program directory>\TH260 Driver” (<program directory> may be e.g. 
c:\Program Files(x86)\Risoe). You do not need to install the standard 
software that comes on a disc with the board, for operation with the TL/OSL 
reader. 
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4. Connect START on Controller back to “S” on TimeHarp260. Connect STOP 
on Controller back to “1” on TimeHarp260. Connect ACK on Controller 
back to 15-pin sub-D connector on TimeHarp260. 

 
The Sequence Editor and PTanalyse programs are installed from the “TL/OSL 
Software” disk that comes with the Risø TL/OSL system. The Sequence Editor must 
be V.3.32 or higher. For operation of the PicoQuant TimeHarp 260 board the 
Sequence Editor must be V.4.2 or higher. 
 
The license file (license.ini) for you particular Photon Timer board is copied to the 
directory where the Sequence Editor program is installed. The default directory for 
the Sequence Editor is C:\Program Files\Risoe\TL. If the license file is lost, a copy 
may be obtained by contacting Risø (osl@ntech.dtu.dk)  

3. How to acquire Photon timer Data 
 
For acquisition of Photon Timer data you use the standard Sequence Editor program. 
To be able to acquire Photon Timer data, you need to mark the Pulsing and Photon 
Timer options in the System Options as shown in the figure below 
 

 
 
 
To acquire Photon Timer Data from a Pulsed OSL stimulation you just mark 
“Enable Photon Timer data acquisition” as show in the POSL dialog in the figure 
below 
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For each POSL command with Photon Timer enabled, a Photon Timer data file is 
generated. The name of the file is derived from bin-file name, run no., set no. and 
sample no:  
 
<bin-file name>_<run no><set no><sample no>.<PTdata extension> 
 
<PTdata extension> = TRC for the ORTEC board and =PQ2 for the PicoQuant 
board. 
E.g. Q091026_010225.PQ2 is the file containing Photon Timer data from run=1, 
set=2, sample=25 of the data acquisition that produced bin-file Q091026.bin.  

4. How to analyse Photon timer Data 
 

4.1. Open file 

For presentation and analysis the program PTanalyse is used. 
 
You may open the individual .TRC or .PQ2 files either directly via File→Open file... 
or from a set of .TRC /.PQ2 files associated with a .BIN/.binx file via File→Open 
data set... 
 
If you chose to open via a data set, you are prompted for a name of the .BIN file that 
was generated from the run. When the .BIN file has been selected you may chose the 
individual .TRC files via the list box as shown below 
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After opening the file, a 3D surface plot of the data is shown. 
 
All data are time-stamped with a resolution of 100 ps. The stimulation period  =  on-
time + off-time is divided into a number of  Photon arrival time bins, and the total 
stimulation time is divided into a number of Stimulation time channels. The 3D 
surface plot shows the Photon counts accumulated in Photon arrival time bins and 
Stimulation time channels.  
 

4.2. TR-POSL surface plot 

4.2.1. Changing bin width 

The Photon arrival time bins are time intervals for the photon arrival time relative to 
the start of the stimulation pulse. The minimum bin-width (or time stamping 
resolution) is 0.1 or 1.0 ns depending on your Photon Timer board (Ortec: 0.1 ns, 
TimeHarp: 1.0) and may be changed in steps of a factor of 2. I.e. the bin width can 
be changed to 2n × minimum bin-width, where n = 1,2,3,...... When you have 
changed the bin width, the Update plot-button is enabled, and the plot may be 
updated with the new bin width by pressing this button. 
 

4.2.2. Changing channel width 

The Stimulation time channels are acquisition time intervals relative to the start of 
the acquisition. You may choose a channel width as an integer number of pulse 
periods. When you have changed the channel width, the Update plot-button is 
enabled, and the plot may be updated with the new channel width by pressing this 
button. 
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4.2.3. Rotation of the 3D surface 

If you press the left mouse button on the surface plot, the outline of the 3D plot is 
show by vertexes of a box.  
 

 
Keeping the mouse button down and moving the mouse at the same time allow you 
to change the angle from which you see the surface. When you release the mouse 
button the surface plot is redrawn with the new angle of view. 
 

4.2.4. Scaling of the 3D surface 

By default the axis are scaled automatically, but you may manually define the 
minimum and maximum of each axis. You do this by 

 removing the check mark in the Auto-column 
 entering valid minimum and maximum parameters 
 pressing the Rescale-button 

 
If you mark the Auto-checkbox the plot is automatically rescaled 
 

4.2.5. Save plot 

If you press the Save Plot-button you are prompted for a bitmap (.bmp) file name. 
The current surface plot will then be stored as a bitmap file that may be printed out 
directly or used in e.g. Word documents. 
 

4.2.6. Export 

If you press the Export-button you are prompted for a name of a Comma Separated 
Values text (.csv) file. All the data of the current surface plot including acquisition 
and plotting parameters are stored. The file format may directly be read by e.g. 
spreadsheet programs. In the figure below is shown a part of a file, read by Excel: 
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4.2.1. Export Set  

This button is in the “Data set” group. This button is used for exporting all processed 
data from the entire photon timer data set. You may chose to export either Surface 
plots to CSV text files, Pulsed OSL curves to BIN files or Photon arrival time 
distributions to BIN files by pressing the appropriate radio button. 
 
When the “Export set” button is pressed, the first processed data (Surface plot, POSL 
curve or PAT distribution) is shown. You may change the parameters for the data 
processing (cf. 4.2 TR-POSL surface plot, 4.3 POSL curve, or 4.4 Photon Arrival 
Time distribution) before saving. If you change parameters, remember to press 
“Update plot” before saving: 
 

 
 
You may then choose between  

 Save current (exports the currently shown processed data) 
 Save all (exports the currently shown and all remaining processed 

data) 
 Skip current (skips the currently shown processed data) 
 Skip all (skips the currently shown and all remaining processed data) 
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4.2.2. Options 

In the File→Options dialog you may change axis units and other plotting 
parameters. You may furthermore store the settings as default settings that are 
applied when you open the program again. 
 

 
 
In the Mode box you select the board that your Photon Timer attachment is equipped 
with. 
 
The photon arrival time may be given in either bin no. or as time in µs.  
If you select bin no. as the unit, the stimulation period is written on the plot. 
If you select time in µs as the unit, the bin width is written on the plot. 
 
The stimulation time may be given in either channel no. or as time in s.  
If you select channel no. as the unit, the total stimulation time is written on the plot. 
If you select time in s as the unit, the channel width is written on the plot. 
 
The photon counts may be given in ether counts/bin/channel or as count rate in 
kcnt/s (kilo counts per second) 
 
You may select between 3 different appearances of the surface and choose the 
default setting of the bin width and the channel width. 
 
If you press the Save as default-button, the setting is stored in the file PTanalyse.cfg 
which is read when the program is started. 
 
 

4.3. POSL curve 

You may want to see the decay of the signal obtained in a certain photon arrival time 
interval. This corresponds to gating the signal in the POSL command with the Pulsed 
OSL attachment. However, with the Photon Timer you do the gating after the 
acquisition and several gating intervals may be defined without any limitations. 
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For this you select View→POSL curve. The plot starts out with one gating period or 
Photon arrival time interval covering all the stimulation period. You may freely 
define up to 5 different Photon arrival time intervals. When the Update plot-button 
is pressed the corresponding POSL curves are plotted as shown in the figure below 
 

 
 

4.3.1. Scaling 

With the  and  buttons you may scale the plot. You may also use the mouse 
to zoom into a particular part of the plot: Press the left mouse button on the upper 
left corner of the region you want to expand, and draw the mouse to the lower right 
corner of the region you want to expand. The region is marked with a green line 
pattern as shown in the figure below, and when you release the button, the plot is 
expanded to show the marked region.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 

To rescale the plot automatically you may press the  button 
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4.3.2. Save plot 

If you press the Save Plot-button you are prompted for a bitmap (.bmp) file name. 
The current POSL curve plot will then be stored as a bitmap file that may be printed 
out directly or used in e.g. word processor documents. 
 

4.3.3. Export to CSV 

If you press the Export to CSV-button you are prompted for a name of a Comma 
Separated Values text (.csv) file. All the data of the current POSL curve plot 
including acquisition and plotting parameters are stored. The file format may directly 
be read by e.g. spreadsheet programs. In the figure below is shown a part of a file, 
read by Excel: 
 

 
 
 

4.3.4. Export to BIN 

If you press the Export to BIN-button you are prompted for a name of a BIN file 
(The default name is the name of the TRC/PQ2 file). If you have more than one 
“Photon arrival time interval” a section for each interval is stored in the BIN file. 
The  “Photon arrival time interval” parameters are stored in the comment field so 
you will be able to distinguish the data (because they will all have the same run, set 
and sample ID). They will also be given a different Curve No., which is a header 
parameters that is shown with Version 4 or later of the Viewer program. 
 
 

4.4. Photon Arrival Time distribution 

The Photon arrival time distribution within the stimulation period may change 
during the total stimulation time. You may plot the Photon arrival time distribution 
in specified time intervals by selecting View→Photon arrival time distribution. The 
plot starts out with one Stimulation time interval covering all the total stimulation 
time. You may freely define up to 5 different Stimulation time intervals. When the 
Update plot-button is pressed the corresponding photon arrival time distribution 
curves are plotted as shown in the figure below 
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4.4.1. Scaling 

Scaling is done with mouse and buttons as described in 4.3.1 
 

4.4.2. Save plot 

The Save Plot-button works just as the button on the TR-POSL surface plot window 
(4.2.5) and the POSL curve window (4.3.2). 
 

4.4.3. Export to CSV 

If you press the Export to CSV-button you are prompted for a name of a Comma 
Separated Values text (.csv) file. All the data of the Photon Arrival time Distribution 
plot including acquisition and plotting parameters are stored. The file format may 
directly be read by e.g. spreadsheet programs. In the figure below is shown a part of 
a file, read by Excel: 
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4.4.1. Export to BIN 

If you press the Export to BIN-button you are prompted for a name of a BIN file 
(The default name is the name of the TRC/PQ2 file). If you have more than one 
“Photon arrival time interval” a section for each interval is stored in the BIN file. 
The “Photon arrival time interval” parameters are stored in the comment field so you 
will be able to distinguish the data (because they will all have the same run, set and 
sample ID) 
 
 


